1. François Van Lerberghe
  2. as Embedded Server
  3. Freitag, Oktober 15 2021, 10:24 AM
  4.  Abonnieren via E-Mail

I cannot load VServer in a new installation. The error log say :
"Valentina server ssl private key or certificate error"

Config : MacOS Catalina 10.15.7
In the .ini file, I have

; Secure port to listen by VServer.
; 0 - do not use a secure port.

; The path, where a certificate is stored.

; The path, where a private key is stored.

Adding both file (dummy.pem and key.pem) or not give me the same error.
In many other install, i've not added this files and this is working like a charm when I issue "sudo launchctl load [my plist file]" line in the Terminal.

Do you have some idea why I get this error ?
There are no comments made yet.
François Van Lerberghe Akzeptierte Antwort
And the logs say me that the INI file is incorrect, despite the fact that it's strictly the same as in other install !

I tried to load without ini file. The server created its own ini file. Next I change all the properties in order to set them with my values. Bingo : it's loading now.
The differences are only 1) the case of property name and 2) without spaces between name property and value
The load working now : my INIT file is read.

... but still an error : the VServer says that my license file is not valid. Grrrr.
I've removed the quarantine attribute, but no success reading it by the server.
Some idea about that ?
There are no comments made yet.
Ivan Smahin Akzeptierte Antwort
Strange. Could you send me an original ini file for testing?
There are no comments made yet.
François Van Lerberghe Akzeptierte Antwort
Found the problem :p
I gone to the System Preferences > Privacy and Security : All files and folders and check the box for VServer
Now VServer is allowed to read the licence file.
(and I suppose the .ini file problem was the same but as I let the server create a new one it is allowed to read it also).
There are no comments made yet.
  • Seite :
  • 1

There are no replies made for this post yet.
However, you are not allowed to reply to this post.