1. Cecilio
  2. Valentina Reports ADK
  3. Donnerstag, September 14 2017, 05:09 PM
  4.  Abonnieren via E-Mail
Hello again.

With Xojo r1.1 everything was fine, I unzipped the r2.2 I passed the plugins "ValentinaPlugin" to the plugin folder of r2.2. Also the v4rg and v4_x64 library files in Xojo Libs.

When I open projects using valentina reports made with version r.1.1 it goes fine. In version r2.2 they are interrupted when initializing the report.

Does anyone know if there is anything else to do?

(use linux Mint, 64bits.)
Kommentar
There are no comments made yet.
Ruslan Zasukhin Akzeptierte Antwort
Hi,

* I wonder, r1.1 and r2.2 this is about Xojo IDE? This is something new of 2017 year?

* We have Video and wiki page about how to install on linux.

* Do you run IDE on linux or already compiled app?

* v4_x64 library files in Xojo Libs. -- you mean files of our vcomponents folder? I think they should go to /usr/local/lib/vcomponents
Kommentar
There are no comments made yet.
Cecilio Akzeptierte Antwort
* I wonder, r1.1 and r2.2 this is about Xojo IDE? This is something new of 2017 year?

Yes, is Xojo IDE new update 2017 (xojo2017r2.1)

* We have Video and wiki page about how to install on linux.

Is empty: roducts:adk:v4rb:manual:installation:linux" target="_blank" rel="nofollow">Install on linux

* Do you run IDE on linux or already compiled app?

In IDE:

Dim f As FolderItem = Camino(Proyecto) // Paht to project.vsp

try
Valentina.InitReports(LRmac, LRwin, LRlin)
mProjectPath = f
mProject = new VProject(mProjectPath)

mProject.Open()

Vconnect = vConn
Exception err as VException
dim errNumber as Integer = err.ErrorNumber
MsgBox(err.Message)
end


breack at "mProject.Open()", and no exception is show.

* v4_x64 library files in Xojo Libs. -- you mean files of our vcomponents folder? I think they should go to /usr/local/lib/vcomponents

Yes, and a copy en Xojo Libs.
The interesting thing is that in xojo r1.1 it works fine.
Kommentar
There are no comments made yet.
Cecilio Akzeptierte Antwort
Any idea what I can do?
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hi Cecilio,

I'll set up the same environment and check what's wrong in the nearest time.
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Hi Cecilio,

Reproduced this problem: the application compiled in Xojo 2017r2.1 stops on VProject.Open, no information added to the log.
With r1.1 works fine.
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
The problem is reproducible only for 32-bit application, in 64-bit everything is fine.

1) It is a 32-bit application, right? What if you switch application to 64-bit mode and try again?
2) Have you tried to run compiled 32-bit application? The same problem?
Kommentar
There are no comments made yet.
Cecilio Akzeptierte Antwort
effectively, in 64-bit works fine. !!

Will it be solved for 32-bit?
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
That's a strange crash - I can't find out what's wrong yet.

On development system (it is an old release of Xubuntu) it works.
On Ubuntu 17.04 didn't work at the beginning but works now after some restart.
Kommentar
There are no comments made yet.
  • Seite :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories