1. B M
  2. Valentina Studio
  3. Freitag, Februar 15 2019, 06:29 PM
  4.  Abonnieren via E-Mail
It appears that 9.0+ handles NULL differently than its counterpart version 8. Version 8 correctly was setting a NULL value in a field of it was set as 'NULLABLE' and no value provided. Version 9 no longer does it. This will create problems when queries are written with explicit NULL filters. See attached screen-shot. What was a reason for this change? It was working fine the way it was before. Now I consider it broke.
Anhänge
Kommentar
There are no comments made yet.
Ruslan Zasukhin Akzeptierte Antwort
9.0.3 - is on site now with this fix.
Kommentar
There are no comments made yet.
B M Akzeptierte Antwort
When can we expect this fix? It's really biting me with anything that would enter a NULL as a default value.
Kommentar
There are no comments made yet.
Sergey Pashkov Akzeptierte Antwort
Yes, previous behavior was correct.
Returned back setting a NULL value for nullable field in a new record
Kommentar
There are no comments made yet.
  • Seite :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories