Switch to: V14V13V12V11V10V9V8V7V6V5

Start Page Help

When you start Valentina Studio for the first time you will always see the Start Page. The Start Page gives you easy access to databases and projects. It has three primary regions:

  • Servers. These include Bookmarks to database servers as well as Valentina Server, running on a network. (Postgre SQL, MySQL, MariaDB, MongoDB and other databases supported by Valentina Studio)
  • Databases. These are local databases that are not 'served.' (ValentinaDB, SQLite and other local databases supported by your version of Valentina Studio)
  • Projects. Valentina Project files contain Reports, Forms, Diagrams and anything else that can be stored in a Project File

The Start Page is the default Workspace of the Main Window of Valentina Studio. Adding custom Workspaces is a feature of Valentina Studio PRO.

Working with Remote Servers

On the left side of the Start Page, you can see and work with remote servers.

  • Bookmarks list. For each bookmark, you can see on its right red or green ball, which indicates the current status of the server. The title of the “Bookmarks” list has a contextual menu with the Refresh command, which allows you to force refresh the state of bookmarked servers. On default, Valentina Studio refreshes it once per minute. You can disable this feature in the preferences of Valentina Studio.
  • Recent Connections list. Choose one and by single click open it. The right-click on a recent item opens a contextual menu where you can delete the item. To delete all items in the list you can choose the menu “File → Open Recent Connections → Clear” or right-click on the title of the list “Recent Connections”.
  • Create Bookmark…button. Add a new bookmark that allows you to immediately connect to a remote server.
  • Connect to… button. that opens the Connect Dialog to establish a new connection to a remote DB server (Valentina Server, Postgre SQL, MySQL, … ).

Working with Local Databases

In the middle area of the Start Page you have the following options:

  • Recent Local Databases list. Single click a database to open it. Right-click on a recent item opens a contextual menu where you can delete the item. To delete all items in the list, select menu “File → Open Recent Database → Clear” or right-click on the title of the list “Recent Local Databases”.
  • New Database… button. Select an option to choose between Valentina and SQLite database.
  • Open Local Database… button. Opens the standard Open Dialog of your operating system where you can choose:
    • a Valentina database file (.vdb)
    • an SQLite database file (can have a different extension)

Working with Valentina Projects

Valentina Project Files are special container files that can exist on local storage or stored in Valentina Server.

On the right side of the start page you can see:

  • Recent Projects List. Double-click to select and open recently opened Valentina Projects or, open example Valentina Projects from the Paradigma Software website. The right-click on a recent item opens a contextual menu where you can delete the item. To delete all items in the list you can choose the menu “Project → Open Recent Project → Clear” or right-click on the title of the list “Recent Projects”.
  • New Project… button. Select a sub-menu item to choose between LOCAL or SERVER locations for the new Project file.
  • Open Project…button. Select a sub-menu item to choose between LOCAL and SERVER locations for the new Project file.