Switch to: V10V9V8V7V6V5

File Menu Help

The “File” menu allows you to open and save files, import from and export to files and accessing the print functions.

File Menu

New Window

Opens one more Main Window. Rare used because usually you will prefer to work with many Tab-panels inside of the first main window.

Close Window

Closes the main window.

Close Tab

Closes the current Tab-panel.

New Database...

Opens the "Create New Database" dialog to create a new Valentina or SQLite local database.

Open Database...

Opens the “Open Database” dialog to choose Valentina or SQLite local database file.

Close Database

Closes the current/selected database in the Schema Editor.

Close All Databases

Closes all open databases.

Connect To...

Opens the “Connect to Valentina Server” dialog, thus allowing to connect to a VServer in order to eg. access a database on that server.

Bonjour

Opens a connection to any registered Bonjour Servers

Bookmarks

Add Bookmarks...

Clear...

Edit...

Open Recent Connection

Allows to open a recent connection to Database Server.

Open Recent Database

Allows to open a recent local database file.

Save

Saves the current/selected object.

Save All

Saves all changes of all opened objects.

Export to CSV...

Opens the Export Text dialog where you can export records of a database table into text format.

Import to CSV...

Opens the Import Text dialog where you can import records from text format into a database table.

Make Dump...

Opens Create Dump wizard that helps you export database into SQL/XML/Excel dump file.

Load Dump...

Opens Load Dump wizard to choose a SQL/XML dump file on disk to load it into existed database or create new database from that dump file.