Switch to: V9V8V7V6V5

Start Page Help

When you start Valentina Studio for the first time you will always see the Start Page. The Start Page gives you easy access to databases and projects. It has 3 main areas to work with:

  • Valentina Projects (containing Reports, Forms, Diagrams and more)
  • Local Databases (Valentina DB and SQLite and other local databases supported by Valentina Studio)
  • Remote DB Servers (Valentina Server, Postgre SQL, mySQL and other databases supported by Valentina Studio)

Working with Valentina Projects

On the right side of the start page you can see:

  • A list of “Recent Projects” that you can click to select and open. Right click on a recent item opens contextual menu where you can delete the item. To delete all items in the list you can choose menu “Project → Open Recent Project → Clear” or do the right click on the title of the list “Recent Projects”.
  • New Project… button with sub-menu to choose between LOCAL and SERVER locations of the project file.
  • Open Project…button with sub-menu to choose between LOCAL and SERVER locations of the project file.

Working with Local Databases

In the middle area of the start page you can see:

  • List of “Recent Local Databases” where you can choose one and by single click open it. Right click on a recent item opens contextual menu where you can delete the item. To delete all items in the list you can choose menu “File → Open Recent Database → Clear” or do the right click on the title of the list “Recent Local Databases”.
  • Button “Create Local Database” that has sub-menu to choose between Valentina and SQLite database.
  • Button “Open Local Database …”, which opens that standard Open Dialog of your OS where you can choose
    • a Valentina database file (.vdb)
    • a SQLite database file (can have different extension)

Working with Remote Servers

On the left side of the Start Page you can see and work with remote servers.

  • Two lists.
    • The “Bookmarks” list. For each bookmark you can see on its right red or green ball, which indicates the current status of the server. The title of the “Bookmarks” list has contextual menu with Refresh command, which allows you force refresh state of bookmarked servers. On default Valentina Studio refresh it once per minute. You can disable this feature in the preferences of Valentina Studio.
    • The “Recent Connections” list, where you can choose one and by single click open it. Right click on a recent item opens contextual menu where you can delete the item. To delete all items in the list you can choose menu “File → Open Recent Connections → Clear” or do the right click on the title of the list “Recent Connections”.
  • Create Bookmark button allows the creation of new bookmarks
  • Connect to… button that opens the Connect Dialog to establish a new connection to a remote DB server (Valentina Server, Postgre SQL, mySQL, … ).