1. nieko baarda
  2. Valentina Studio
  3. Thursday, March 26 2020, 08:34 PM
  4.  Subscribe via email
In Data Editor all fields without values display <NULL> how can I configure the display so fields with <NULL> display as empty fields ?
Attachments (1)
Comment
There are no comments made yet.
nieko baarda Accepted Answer
Thanks for help.

If flag of fields unchecked Nullable before import csv file, empty fields show empty.

I need to do this by first create fields that exist in the csv file.

The first row of my csv file contains the field names.

So I need, when not creating table and fields by myself, in the Import Wizard the option setting Nullable / NoNullable for fields of the csv file, if importing a table (fields and values).
See attachment:
valentina_import_table_auto_check_nullable.jpg

Do I something wrong when importing in the Import Wizard a table (fields and values) without first creating the table and the fields ?
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 1
Ruslan Zasukhin Accepted Answer
Nieko Baarda
Suggestions from (person) chat-bot Paradigma solved my question.
Fields where checked (v) for Nullable before import csv file.
Changed flag by uncheck Nullable. Than import csv file and empty fields show empty. Thanks for help.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 2
Sergey Pashkov Accepted Answer
There is no such option for the Data Editor.

But as Pierce suggested you can use a Nullable flag.
Most probably SQLite will not allow you to change the Nullable flag when data is in the table.
So you can set it for a new table before adding/importing records to this table.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 3
Pierce DuBrock Accepted Answer
Edit the tables fields and turn off the nullable flag?. This what you are after?.
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.