1. Trevor Campbell
  2. Report Editor
  3. Tuesday, April 07 2020, 05:21 AM
  4.  Subscribe via email
I have a report with a subreport. = Report 1.jpg

When I preview the report the first page works fine, but then elements of the report randomly doesn't print. Shown Report Page 1 and Report Page 2.

I'm trying to figure out what would cause this.
Attachments (3)
Comment
There are no comments made yet.
Trevor Campbell Accepted Answer
Hi Sergey,

Thanks for your suggestion. I tried it and I have managed to get it to work by making some tweaks.

Thanks
Trevor
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 1
Sergey Pashkov Accepted Answer
Hello Trevor,

Looks like it is related to subreport layout.
Did you try to group by dept_name instead of adding a subreport?
It works better in my tests, however, I can't get exactly the same results.
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 2
Trevor Campbell Accepted Answer
Here is a screenshot of page 2 with Borders and Names checked.

Thanks
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 3
Sergey Pashkov Accepted Answer
What do you see if you turn on Borders and Names options on Profile tab in preview mode for Report Page 2? What controls are placed in the first column if any?
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 4
Trevor Campbell Accepted Answer
Hi Sergey,

I have attached a project with the Report and Subreport.
The SQL for the report is :

select * from "user"."tbl_name"


The SQL for the subreport is :

select * from "user"."tbl_name" where tfi_detail_id = $P(det_id)


I have also attached a csv of the data for the table. First row is field names.

I am currently using Version 8.
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 5
Sergey Pashkov Accepted Answer
Hello Trevor,

What version is used?
If you can send report and subreport layouts with data (SQL/CSV) for first pages - that would help a lot.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Report Editor
  3. # 6
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.