1. Eleanor Jones
  2. Valentina Studio
  3. Thursday, July 02 2020, 11:09 PM
  4.  Subscribe via email
Hello,

I've been a new issue with combo box fields that use aliases for their items - specifically when the items are ID numbers and the aliases are words.

In this example there is a table with an ID field and a Name field. The Name field records are not in alphabetical order. Previously, simply pointing the items to the ID field and the aliases to the Name field worked great. But as of yesterday or so the Name field is reordered alphabetically when viewed in the form. It seems like the ID items underneath are in the same order, leading the user to select a hidden and incorrect ID.

Additionally, when choosing a field I cannot uncheck 'Distinct' or 'Sorted'. If I uncheck them, they are checked again upon opening the field choice again and there is no impact on the original issue. Could the 'Sorted' setting be the source of this issue? The ID fields tend to already be in ascending order, but the names are not.

If the lists (items list and alias list) for a particular combo box are based off of a query, there is no issue as both queries can be explicitly ordered in the same way. I am using version 10.4.12 and have had the same issue on MacOS and Windows.

Thank you for your help,

Grace
Attachments (1)
Comment
There are no comments made yet.
Sergey Pashkov Accepted Answer
Hello Grace,

Thank you, I'll check it now
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 1
Sergey Pashkov Accepted Answer
Hello Grace,

Thank you, a new version is available for download.
Now it is possible to sort Items and Aliases by any field in the table.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 2
Eleanor Jones Accepted Answer
Hi Sergey,

Wonderful, thank you so much!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 3
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.