1. Fotis Georgiadis
  2. Valentina Reports ADK
  3. Tuesday, July 12 2016, 01:52 PM
  4.  Subscribe via email
Hello,
On a Xojo application I print using Valentina Reports ADK (latest version). Now on all my test machines works fine. On a specific site I get "Report Error 611604: Datasource error: "[FreeTDS] Unable to connect: localhost :: worktimer".

Using Xojo 2016 Release 1.1, V4RB 6 (V: 6.5.8) Connecting to MSSQL Server, Windows 7 Enterprise...

Any ideas?
Comment
There are no comments made yet.
Sergey Pashkov Accepted Answer
Hi Fotis,

Can you show, how do you specify the datasource string, please?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 1
Fotis Georgiadis Accepted Answer
Hi Sergey,

the string is: mssql://'localhost', user='sa', password='Tng318101', db='worktimer'

The credentials (host, username, password, db name) are correct since they are the same that Xojo uses to connect.

Any ideas?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 2
Fotis Georgiadis Accepted Answer
And I have to say that similar string connects with no problem in other PCs / Server.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 3
Sergey Pashkov Accepted Answer
here host= is missing, or it's just a typo?
mssql://host='localhost', user='sa', password='Tng318101', db='worktimer'

And you can connect to this MSSQL server from the Valentina Studio, right?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 4
Sergey Pashkov Accepted Answer
One thing to check - I remember, there was similar problem and adding a port definition helped:
port = '1433'
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 5
Fotis Georgiadis Accepted Answer
Sergey this is a customer's site. I have not installed Valentina Studio!

I will try adding the port and see what happens...

I will let you know in a few minutes...
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 6
Fotis Georgiadis Accepted Answer
No success with adding the port!

Any other ideas? I will be downloading Valentina Studio to see if I can connect from it to the server!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 7
Fotis Georgiadis Accepted Answer
It seems I can't connect from Valentina Studio as well!

It seems to "see" the server (I am prompted to connect to localhost) however, I cannot connect!

Any ideas? Any protocol that needs to be activated?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 8
Sergey Pashkov Accepted Answer
TCP/IP protocol should be activated. Is it active now?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 9
Fotis Georgiadis Accepted Answer
Hey Sergey,

I just turned on TCP/IP protocol for all types of clients (native 10 etc), since it was only active for one, and it worked!

Sometimes it takes so much for such a simple thing!

Thanks for your support... :)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 10
Jochen Peters Accepted Answer
i have same error MS SQL server 2012

RepStrConn="mssql://host='localhost\\SQLEXPRESS' port='1433' dbname='ADG' user='adgadmin' password='pass123'"
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 11
Sergey Pashkov Accepted Answer
Hi Alexis,

So have you enabled TCP/IP protocol?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 12
Jochen Peters Accepted Answer
thanks
Sergey i fix it with enable tcp/ip on ms sql express

thanks you are big help
:D
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 13
Alexis Colon Lugo Accepted Answer
Hi
i have same error and enabled TCP/IP if anable
RepStrConn="mssql://host='localhost\\SQLEXPRESS' port='1433' dbname='ADG' user='adgadmin' password='passs'"
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 14
Sergey Pashkov Accepted Answer
Hello Alexis,

Did you try to connect from the Valentina Studio? It's much easier to try different server settings.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 15
Alexis Colon Lugo Accepted Answer
i try to connect with VS and no connect but using MS Studio user sa and pass work.
i'am using localhost
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 16
Sergey Pashkov Accepted Answer
MS Visual Studio? Or SQL Management Studio?
Please show the screenshots of their connect dialog and the Valentina Studio.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 17
Alexis Colon Lugo Accepted Answer
MS Management Studio
Attachments (2)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 18
Sergey Pashkov Accepted Answer
Please try to leave the Server input field empty
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 19
Alexis Colon Lugo Accepted Answer
same error
my VST PRO v 8.0.2
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Reports ADK
  3. # 20
  • Page :
  • 1
  • 2


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories