1. Milad Sainam
  2. Valentina Studio
  3. Tuesday, September 06 2016, 11:01 AM
  4.  Subscribe via email
I have been using Valentina Studio 6.5.8. I created a diagram which was saved successfully. I even exported the diagram as a *.vdiagram file. I checked the content of that file and it has some content. After I reopened Valentina Studio I tried to reopen the diagram but this does not work properly. I can select the tables (as I see the selection border) but otherwise no data is visible. I cannot edit anything. Its just an empty grid. I tried to import the *.vdiagram file with the same bad results.

I updated to the current 6.5.12 version. But the problem was not solved.

I would be grateful about any help.

Regards
Milad
Comment
There are no comments made yet.
Sergey Pashkov Accepted Answer
Hi Milad,

What database are you using?
Can you please send *.vdiagram file, to see what's wrong?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 1
Milad Sainam Accepted Answer
Ich use PostgreSQL.

I attached the file.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 2
Milad Sainam Accepted Answer
I use PostgreSQL.

I attached the file.
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 3
Sergey Pashkov Accepted Answer
Thank you, I've found a few problems.

Does schema "plano" exist in the database?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 4
Milad Sainam Accepted Answer
Thanks for the quick replies.

The database name is "plano". The schema is called "public".
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 5
Sergey Pashkov Accepted Answer
Diagram structure was saved with mistake.
I've fixed wrong schema name in the file and reimported it, now it works for me.
But I can't reproduce original problem yet.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 6
Sergey Pashkov Accepted Answer
Diagram structure was saved with mistake.
I've fixed wrong schema name in the file and reimported it, now it works for me.
But I can't reproduce original problem yet.
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 7
Milad Sainam Accepted Answer
Thank you. I can import the fixed file.

I think I created the schema while not being connected to the database (I think the table list on the left side was empty).

Trying to reproduce it with current 6.5.12 version I found a crash:
1. I connected to my PostgreSQL database. I did NOT open the database "plano" (by double clicking it or what ever).
2. I changed to view "Show database schema as diagrams"
3. I clicked "Create Diagram..." while the database "plano" is selected.
4. Program will crash.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 8
Milad Sainam Accepted Answer
The crash report has been send to you.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 9
Sergey Pashkov Accepted Answer
Hi Milad,
Many thanks for your information.
We'll fix these issues for the next release.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 10
natalie meyers Accepted Answer
newbie user and I have a similar problem - I can see and use a schema for a local db in Valentina Studio in Schema Editor .

I can output a file using the Diagram -> Export Diagram feature.
I cannot re-open that file in Valentina Studio without an error.
Any Suggestions?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 11
Sergey Pashkov Accepted Answer
Hello Natalie,

Export is used to copy a diagram to another database or to another system.
So in the first database you use Diagram->Export Diagram feature which creates *.vdiagram file on disk.
In the second database you use Diagram->Import Diagram, point this *.vdiagram file and it fails with an error.

Is that right or you need to do something different? What was the error text?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Valentina Studio
  3. # 12
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories