1. Christian Breu
  2. Other Discussions
  3. Sunday, April 23 2017, 06:52 AM
  4.  Subscribe via email
Another question about Deployment of V4RB...

I am building an Application on MacOS X to run on Linux.
Is it possible to prepare for deployment of V4RB (on the Mac for Linux)?
How to do it?


btw.
I use v 6.6.9.
The downloadlink for this older version is not visible by Firefox on Linux on your website.
And after copy the downloadlink from Mac, the installation on CentOS 7 fails!
Comment
There are no comments made yet.
Christian Breu Accepted Answer
Ok, got it – sorry for the mess!

Two mistakes found...
Still used the v7.1.2 plugin even everything else was on v7.1.3.
And some messed up situation in the lib folders, copied by build script.

We should not work too late and should check everything again, even it worked before. ;)
Sorry again for that!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 1
Christian Breu Accepted Answer
Thank you for your answer Sergey.
Try-catch does not make a difference – app crashes without any info.
Have only Remote-Debugging.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 2
Sergey Pashkov Accepted Answer
Can't find anything wrong with the connection to a server, the fix at its place.

So if an application starts and doesn't crash immediately it can find all necessary libraries.

There is try-catch around VConnection.Open, right?
Don't you have Xojo installed in Linux to debug code before the crash happens?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 3
Christian Breu Accepted Answer
Did you find out anything Sergey?
Should I downgrade to v7.1.2?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 4
Christian Breu Accepted Answer
Connecting to the VServer...
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 5
Sergey Pashkov Accepted Answer
Crash on an attempt to connect to the VServer?
Or crash on start?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 6
Christian Breu Accepted Answer
I am sorry for that but I think I did not do anything wrong.
And it worked with v7.1.2
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 7
Sergey Pashkov Accepted Answer
Hi Christian,
That's very strange.
I'm installing a new version right now.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 8
Christian Breu Accepted Answer
Proofed – as before.
Mac version works, Linux version crashes... :o :(
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 9
Christian Breu Accepted Answer
Hi Sergey

Cause I was updating just installed v7.1.3.
Face again app crash as with 6.9.9!?
Any idea?

Kind regards.

Chris
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 10
Christian Breu Accepted Answer
Hello Sergey

Just to let you know...
Updated to V7.1.2 – Problem seems to be solved. :)

Thank you again!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 11
Christian Breu Accepted Answer
Hello Ruslan

Hope not having any Problems because of updating to V7.1.1 ;)
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 12
Ruslan Zasukhin Accepted Answer
As I see it is fixed.
Will be available in 7.1.1
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 13
Christian Breu Accepted Answer
Ok thank you Sergey.
We already plan to update – VServer and all of connecting Apps.
Hope not to face any problems about this.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 14
Sergey Pashkov Accepted Answer
The problem was in string initialization on Linux in client mode.
Fix will be available in the version 7.1.1
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 15
Sergey Pashkov Accepted Answer
No, no known issues with the update.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 16
Christian Breu Accepted Answer
Thank you Sergey.
Will try later and let you know about the result.

Just my question again: any known issues about updating from 6.6.9 to 7.1?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 17
Sergey Pashkov Accepted Answer
7.1 behaves the same.
However with Valentina.Init( 10 * 1024 * 1024 ) before Valentina.InitClient it works - so something is broken in strings.
Could you please try to add this line with 6.6.9 plugin version?

I think we will fix it and release a new version.
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 18
Christian Breu Accepted Answer
Thank you for that Sergey.
At least I am not alone anymore...


The productive DB is on 6.6.9 actually.
Can you guarantee no problems when updating from 6.6.9 to 7.1?
Just did not update yet – never change a running system!
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 19
Sergey Pashkov Accepted Answer
My test application worked for local connection, but when I try to connect to VServer I have a crash, too.
I'm checking, what is wrong.

Is it necessary to use version 6.6.9? Or something wrong with newer builds?
Comment
There are no comments made yet.
  1. more than a month ago
  2. Other Discussions
  3. # 20
  • Page :
  • 1
  • 2


There are no replies made for this post yet.
However, you are not allowed to reply to this post.
Sorry, the discussion is currently locked. You will not be able to post a reply at the moment.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories