1. Helge Tjelta
  2. as Valentina DB Server
  3. Wednesday, January 03 2018, 07:43 PM
  4.  Subscribe via email
Hi, I have tried to run VServer on a windows 2016 image on AWS (amazon).

Running it internal works, but when trying to reach it from my local computer (mac) running VStudio, it get no luck...

I have opened port 15432 in the sequrity at amazon, and also added it inside ports of windows os.... what more will I have to do for it to allow me to connect to my server on the AWS machine ???
Comment
There are no comments made yet.
Ivan Smahin Accepted Answer
You can check that port really available. Something like

telnet host port


and type there anything. If port is available you will get some "garbage" on the screen from vServer.

Probably you made more changes to vServer ini like ACCESSCONTROLLIST - if so, please send me that ini, so I can be more specific.
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 1
Helge Tjelta Accepted Answer
sorry but my mac/terminal does not have telnet..., ping does not work...

but I can run a webapp using port 9000 (have opened up for that), no prob... but Vserver can not be reached...
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 2
Ivan Smahin Accepted Answer
You may use ssh instead of telnet - no problem. You need just some tool to check port (not only host) availability.
Mac's "Network utility" could be helpful as well...

Anyway, it is a question for Amazon mainly - not Valentina.

The only thing you should understand - if you send anything (any garbage) to vServer, then vServer disconnects your connection sending error packet before, and you will see this in the output. This fact can be used to check - is the port available + is there vServer, listening for connections.
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 3
Helge Tjelta Accepted Answer
Hi, I've tried many times now... but opening 15432 does not do it.. and looking on the server from VStudio internaly on ther server reports connection of 53XXX og 62XXX and such....

Could someone at paradigma please try to make VServer run on an free tier EC2 Amazon virtual server. And tell us what ports to open... it does not work with adding it to the windows firewall ...please HELP.
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 4
Ivan Smahin Accepted Answer
Please check again Amazon firewall settings. If you have a few AWS instances then probably you were tuning another instance (wrongfully)? Please send me a screenshot of firewall settings (that one with opened vServer's port) and screenshot of instance properties (to make sure that tuned firewall is assigned to expected AWS instance).
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 5
Ivan Smahin Accepted Answer
One more thing:

Please check vServer ini to be:
1. VERBOSELEVEL = 3 (just for now to see max vServer events in the log);
2. PORT_NOTIFICATION = 0 (probably it is the reason - let's check it).

Also, please check vServer logs - is there any records?
I hope you are connecting from vStudio using "connect to" dialog - not waiting for Bonjour (it would not work since there are different networks for vClient and vServer).
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 6
Lynn Fredricks Accepted Answer
Helge - have you tried Sergey's suggestions?
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 7
Helge Tjelta Accepted Answer
Hi , problem found... I had to set the amazon security group to allow port 15431-15436.... if I leave out 15436 I can not connect... strange ??? since I'm using 15432 as connection port (standard).

Now it works. but why 15436 ?
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 8
Ivan Smahin Accepted Answer
It is default PORT_NOTIFICATION (see vServer ini). This port is used to get asynchronous notifications from vServer.
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 9
Helge Tjelta Accepted Answer
OK, that explains it. Thanks.
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 10
Ruslan Zasukhin Accepted Answer
So exists 2 choices:

1) disable notifications port in the INI file of Vserver
2) open ports you going to use.

You can see list of all ports, which VServer can use in its INI file.
Exists yet for REST, SQLite, ...
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 11
Helge Tjelta Accepted Answer
Now I've come further. But now I run into error msg on my windows.... on mac it runs fine...

I have copied according to the deployment of xojo windows...
Attachments (2)
Comment
There are no comments made yet.
  1. more than a month ago
  2. as Valentina DB Server
  3. # 12
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories