1. Richard Albrecht
  2. Report Editor
  3. Wednesday, February 05 2020, 10:15 PM
  4.  Subscribe via email
I have a Membership card that is 102 mm Wide by 59 mm High.

No matter what I try I can not get the Paper format to be close to that size. I set it a little larger but when I apply it and print to PDF it has lots of blank space top and bottom. I want the pdf to come out the same size as the card dimensions.

How can I achieve this?

Attached is the card on a full page. Well I tried to attach, PDF is not supported????

Any chance of doing a remote session, I can send you a zoom link.
Comment
There are no comments made yet.
Sergey Pashkov Accepted Answer
Hello Richard,

1. Project->Edit Paper Formats...
2. Create New
3. Set width=59, height=102, margins to 0 (height should be always bigger than width)
4. Select this format for the report
5. Set landscape orientation
6. Select Page Body region
6. Set margin_bottom=0, margin_top=0
7. Uncheck auto_size, to avoid skipping an empty space at the top of the card
8. Check new_page, to print each card on a separate page

You can add PDF to archive and attach.
Attachments (6)
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 1
Richard Albrecht Accepted Answer
Getting: 08:10:08 Page 1: Area report body 'reportbody1' too big to fit in page

The query returns only one record. These are going to be emailed to Members so we don't have to send hard copies anymore.
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 2
Sergey Pashkov Accepted Answer
Try to move the bottom line of the page body to the top, maybe a few millimeters.
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 3
Richard Albrecht Accepted Answer
There is no bottom line, the card has a graphic that is currently selected in screen shot.
Attachments (1)
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 4
Sergey Pashkov Accepted Answer
I mean handle line that changes the height of the region.
Or just check auto_size property of the page body - it is not necessary to uncheck it for your report layout, controls are placed right at the top of the region.
Attachments (1)
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 5
Richard Albrecht Accepted Answer
I Checked the auto size, Same error. Have a meeting in a few minutes but will respond as soon as clear.
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 6
Richard Albrecht Accepted Answer
I am back
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 7
Sergey Pashkov Accepted Answer
What is the height of this picture in the property inspector? Maybe switch units to millimetres to see an exact value.
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 8
Richard Albrecht Accepted Answer
101.75 mm x 58.50 mm
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 9
Sergey Pashkov Accepted Answer
Strange. And all margins are set to 0?
Attachments (2)
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 10
Richard Albrecht Accepted Answer
There was one not 0, now it's working.:D
Comment
There are no comments made yet.
  1. 2 weeks ago
  2. Report Editor
  3. # 11
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories