1. Lynn Fredricks
  2. BETA Testing
  3. Friday, March 11 2022, 05:00 PM
  4.  Subscribe via email
This is a much requested beta release of Valentina Server and, the following ADKs on ARM 64bit Linux:

  • Valentina for Java
  • Valentina for Xojo
  • Valentina PHP
  • Valentina for Python
  • Valentina for Ruby
  • Valentina C++

Our engineering team would appreciate it if you can download and give these a try and provide us with feedback.

Updates

  • 2022-03-15. 12.1b5 available for download
  • 2022-03-12. 12.1b2 available for download
References
  1. http://valentina-db.com/download/beta/12.1b2/
Comment
There are no comments made yet.
Scott Accepted Answer
For me, ARM64 is for a specific project: I am using an Oracle Ampere ARM64 CPU instance (Ubuntu Server 20.04, NGINX, PHP 8.1.X) on their cloud infrastructure. Oracle requires the use of ssh keys to access your shape. Without ssh keys, you cannot get into the instance.

After ssh'ing into the instance, installing VServer and VPHP was very straight forward and worked just like your typical x86 Debian flavor. I had a small issue getting the Linux free VServer license to be recognized as a valid license. It took a few shutdowns and reboots to get it finally work. After that - BOOM - it works like a champ.

Except: VServer appeared to be looking for a VReport shared lib named ****_x64.so. I looked in the VComponets folder and could only find files with the naming convention ***aarch64,so. I took a chance and just renamed the aarch64 file to x64 and rebooted. Again, it began working like a champ. This was obviously just an oversight when recompiling for ARM64.

Accessing the VServer via VStudio was easy using the SSH key. My Oracle VPS is in the Ashburn, SC area and I am in Florida - the lag was barely noticeable.

I did run into another issue trying to use VReports. Again, using VStudio was easy. Designing was a breeze. You can assign the VServer as the datasource, but, when previewing the reports in VStudio, it tries to connect via SSH and fails. (Ports 22, 15432 - 15436 on Oracle's firewall are opened to TCP)

This may be a set up issue as I am not well versed in working behind an ssh key requirement. I may need help getting this set up.

And lastly, I was able to install VPHP, however, I could not get the php80 extensions to load. I tried on php 8.0 and 8.1 with no luck.

Scott
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 1
Sergey Pashkov Accepted Answer
Hello Scott,

Thank you for the details! VReport library name issue is fixed in beta 2.

What about the SSH server. Is it running in the instance?
So when you connect you specify the SSH server address and set the VServer address to localhost.
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 2
Scott Accepted Answer
Connecting to and using VServer via SSH works flawlessly. Creating a report, datasource, and query work without error. When in the report designer, the editor sees the datafields from the SELECT clause. The error occurs when you preview the report. See the attached screen shots.

Scott
Attachments (3)
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 3
Sergey Pashkov Accepted Answer
Did you get any error messages on VPHP loading? There is only php80_valentina.so the library for PHP 8.0, so 8.1 is not supported yet.

I just tried VPHP on Raspberry Pi 64-bit OS and was able to establish a connection to the server.
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 4
Scott Accepted Answer
Yes - I figured that out earlier. I switched the PHP version to 8.0.X in the Ampere instance and set all the configuration settings for 8.0. I restarted nginx and php8.0-fpm and it now works like a champ.

Before seeing your message about no 8.1 support, I went to the /opt/VPHP folder and noticed there wasn't an 8.1 module.

On a side note, there is an 8.1 module in the Debian x64 VPHP download and I just enabled VPHP under 8.1 on another Ubuntu 20.04 server. That works well on that machine. Will there be support for 8.1 on ARM64?

Scott
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 5
Sergey Pashkov Accepted Answer
Yes, we’ll add it soon.
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 6
Sergey Pashkov Accepted Answer
A new build with PHP 8.1 support is available for download
References
  1. http://valentina-db.com/download/beta/12.1b5/
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 7
Scott Accepted Answer
Thanks so much Sergey!!

I still can't seem to get the VStudio report editor to preview the report on the remote Oracle machine via SSH. I keep getting the same can't establish SSH tunnel error.

I am sure I am doing something wrong in the setup - any ideas?

Scott
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 8
Ruslan Zasukhin Accepted Answer
Hi Scott,

preview does not work with b5 also?
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 9
Scott Accepted Answer
No sir - it doesn't. I reached out to Oracle to see if there are specific connection properties needed
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 10
Scott Accepted Answer
Not that this helps much with the VStudio preview issue, but reports work just fine when accessing them from the webserver to vserver using PHP.

Everything appears to working fine, with the exception of not being able to preview reports in VStudio.

Scott

P.S. I can send you my login credentials and you can see if I have messed something up in the configuration if necessary.
Attachments (1)
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 11
Sergey Pashkov Accepted Answer
Key authentication can be problematic.
Have you tried the latest version of VStudio?
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 12
Scott Accepted Answer
I installed the latest VStudio and I can confirm that is all working fine now.
Comment
There are no comments made yet.
  1. more than a month ago
  2. BETA Testing
  3. # 13
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories