1. Fotis Georgiadis
  2. Valentina Reports ADK
  3. 火, 7月 12 2016, 01:52 PM
  4.  メールで購読
Hello,
On a Xojo application I print using Valentina Reports ADK (latest version). Now on all my test machines works fine. On a specific site I get "Report Error 611604: Datasource error: "[FreeTDS] Unable to connect: localhost :: worktimer".

Using Xojo 2016 Release 1.1, V4RB 6 (V: 6.5.8) Connecting to MSSQL Server, Windows 7 Enterprise...

Any ideas?
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hi Fotis,

Can you show, how do you specify the datasource string, please?
コメント
There are no comments made yet.
Fotis Georgiadis 承諾済みの回答
Hi Sergey,

the string is: mssql://'localhost', user='sa', password='Tng318101', db='worktimer'

The credentials (host, username, password, db name) are correct since they are the same that Xojo uses to connect.

Any ideas?
コメント
There are no comments made yet.
Fotis Georgiadis 承諾済みの回答
And I have to say that similar string connects with no problem in other PCs / Server.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
here host= is missing, or it's just a typo?
mssql://host='localhost', user='sa', password='Tng318101', db='worktimer'

And you can connect to this MSSQL server from the Valentina Studio, right?
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
One thing to check - I remember, there was similar problem and adding a port definition helped:
port = '1433'
コメント
There are no comments made yet.
Fotis Georgiadis 承諾済みの回答
Sergey this is a customer's site. I have not installed Valentina Studio!

I will try adding the port and see what happens...

I will let you know in a few minutes...
コメント
There are no comments made yet.
Fotis Georgiadis 承諾済みの回答
No success with adding the port!

Any other ideas? I will be downloading Valentina Studio to see if I can connect from it to the server!
コメント
There are no comments made yet.
Fotis Georgiadis 承諾済みの回答
It seems I can't connect from Valentina Studio as well!

It seems to "see" the server (I am prompted to connect to localhost) however, I cannot connect!

Any ideas? Any protocol that needs to be activated?
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
TCP/IP protocol should be activated. Is it active now?
コメント
There are no comments made yet.
Fotis Georgiadis 承諾済みの回答
Hey Sergey,

I just turned on TCP/IP protocol for all types of clients (native 10 etc), since it was only active for one, and it worked!

Sometimes it takes so much for such a simple thing!

Thanks for your support... :)
コメント
There are no comments made yet.
Jochen Peters 承諾済みの回答
i have same error MS SQL server 2012

RepStrConn="mssql://host='localhost\\SQLEXPRESS' port='1433' dbname='ADG' user='adgadmin' password='pass123'"
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hi Alexis,

So have you enabled TCP/IP protocol?
コメント
There are no comments made yet.
Jochen Peters 承諾済みの回答
thanks
Sergey i fix it with enable tcp/ip on ms sql express

thanks you are big help
:D
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
Hi
i have same error and enabled TCP/IP if anable
RepStrConn="mssql://host='localhost\\SQLEXPRESS' port='1433' dbname='ADG' user='adgadmin' password='passs'"
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hello Alexis,

Did you try to connect from the Valentina Studio? It's much easier to try different server settings.
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
i try to connect with VS and no connect but using MS Studio user sa and pass work.
i'am using localhost
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
MS Visual Studio? Or SQL Management Studio?
Please show the screenshots of their connect dialog and the Valentina Studio.
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
MS Management Studio
添付ファイル
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Please try to leave the Server input field empty
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
same error
my VST PRO v 8.0.2
添付ファイル
コメント
There are no comments made yet.
  • ページ :
  • 1
  • 2


There are no replies made for this post yet.
However, you are not allowed to reply to this post.