1. John Gold
  2. Valentina Studio
  3. 木, 12月 12 2019, 06:43 PM
  4.  メールで購読
Hey, when I use the "Generate SQL -> Create/Drop/Insert/..." feature in the Schema Editor, the order of the fields is incorrect.

It is not in the order of the field position and cannot be sorted otherwise. So if the first field is "id" in the selection it appears somewhere in the middle for example, which make the whole feature pretty annoying if one wants to select all fields at once. I already checked "Preferences -> Editors -> Schema Editor" where the user can enabled/disabled "Sort Fields", but it only affects the order of displayed fields in the Schema Editor overview.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Fix will be available in version 9.8.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Thank you, we'll fix it in one of the next builds.
コメント
There are no comments made yet.
John Gold 承諾済みの回答
Correct :)
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hello John,

The fields are sorted alphabetically on the Select tab but you need the order specified at the table creation time, right?
コメント
There are no comments made yet.
  • ページ :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.