1. Fotis Georgiadis
  2. Valentina Reports ADK
  3. 火, 7月 12 2016, 01:52 PM
  4.  メールで購読
Hello,
On a Xojo application I print using Valentina Reports ADK (latest version). Now on all my test machines works fine. On a specific site I get "Report Error 611604: Datasource error: "[FreeTDS] Unable to connect: localhost :: worktimer".

Using Xojo 2016 Release 1.1, V4RB 6 (V: 6.5.8) Connecting to MSSQL Server, Windows 7 Enterprise...

Any ideas?
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
I did a clean install of SQL Server Express 2012 and VStudio 8.3.2.

1. Turned on TCP/IP
2. Defined 1433 for TCP Port option in IPAll group
3. Restarted the server
4. Connection from the Valentina Studio established successfully

Do you have any additional antivirus/firewall? In our recent case, it was KIS that prevented VStudio connections while other applications were able to connect.
添付ファイル
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
The description of the datasource strings can be found here.

odbc://dsn = 'access', user = 'name', password = '123'
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
Hi
how i can run using ODBC the reports from XOJO web app.

how i change from "mssql://host='localhost\\SQLEXPRESS' port='1433' dbname='ADG' user='adgadmin' password='dragon'" to use ODBC
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
i try telnet servername 1433 and works but VS no connect to MSSQL Express 2012
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hi Alexis,

ODBC is the completely different way.
Don't you have some strict firewall/antivirus installed?
For example, KIS may block even the local connection, that was discovered recently.

Also, please check that the port is assigned for your localhost connection, like on my previous screenshot.
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
Hi Sergey
VS works but using ODBC but if i use the MSSQL connect from VS no works
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
So now you can connect from VStudio and generate a report, right? What did you change and what are the current settings?
Also, you can use the context menu on the data source on the project tab to view the data source string you can use in code.
Please add this info.
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
i connect with VS but on xojo is the same error on this code >> data = mReport.PrintToBuffer(EVReportPrintType.kToHTML, 1 )
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
can i go VS old version and adk reports this works before 8.0.2
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
is any other way to check the problem ?
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
SSMS may connect using the different way.
Have you defined the port number in the SQL Server Configuration Manager? Please show your settings like on my screenshot
添付ファイル
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
same error
my VST PRO v 8.0.2
添付ファイル
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Please try to leave the Server input field empty
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
MS Management Studio
添付ファイル
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
MS Visual Studio? Or SQL Management Studio?
Please show the screenshots of their connect dialog and the Valentina Studio.
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
i try to connect with VS and no connect but using MS Studio user sa and pass work.
i'am using localhost
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hello Alexis,

Did you try to connect from the Valentina Studio? It's much easier to try different server settings.
コメント
There are no comments made yet.
Alexis Colon Lugo 承諾済みの回答
Hi
i have same error and enabled TCP/IP if anable
RepStrConn="mssql://host='localhost\\SQLEXPRESS' port='1433' dbname='ADG' user='adgadmin' password='passs'"
コメント
There are no comments made yet.
Jochen Peters 承諾済みの回答
thanks
Sergey i fix it with enable tcp/ip on ms sql express

thanks you are big help
:D
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hi Alexis,

So have you enabled TCP/IP protocol?
コメント
There are no comments made yet.
  • ページ :
  • 1
  • 2


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories