1. jaume
  2. Valentina Reports ADK
  3. 月, 9月 23 2019, 05:22 PM
  4.  メールで購読
Hello,

Printing reports with pictures stored in blob field, when blob is null, instead of print none or null, it prints previous picture
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hello Jaume,

What database is used?
What version is used?
コメント
There are no comments made yet.
jaume 承諾済みの回答
Hello Sergey,

The database is Mariadb and version 13
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Unable to reproduce for now.

Can you reproduce it in the Valentina Studio?
What is the version of Valentina Studio?
コメント
There are no comments made yet.
jaume 承諾済みの回答
Hello,

Sorry for the delay.

In valentina studio works fine.

The version is the last (right now) 9.6.1
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hello Jaume,

So the problem only with Xojo application, on what OS is it running?
コメント
There are no comments made yet.
jaume 承諾済みの回答
Xojo on windows

the sql that is send to the report is :
SELECT CONCAT (a.NOM," ",a.COGNOM1," ", a.COGNOM2) AS NOMX, YEAR(a.DATA_NAIXEMENT) AS ANYNAIXEMENT, a.* , b.camp
from v_participants a
left outer join blobs b on a.id = b.id_participant

images are stored in the table blobs
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
And the version of V4RB plugin is 9.6, or?

You can check it in the properties of, for example, vreport_...dll
添付ファイル
コメント
There are no comments made yet.
jaume 承諾済みの回答
The release is 9.1.5
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Can't reproduce for now, even with the same version.
Can you try to compile with the latest version of plugin?
If an update doesn't help/not possible - a small example database and project reproducing this issue would help.
コメント
There are no comments made yet.
jaume 承諾済みの回答
Where can I donload the lastest pluggin ?
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
コメント
There are no comments made yet.
jaume 承諾済みの回答
I've just installed the plugin and compiled, but kthe result is the same.
コメント
There are no comments made yet.
jaume 承諾済みの回答
The result of sql statment returns null in the field camp that is a blob field containing the imag when no there is a image and it is correct. However, in the report insted of print null or empty, it prints the previous image.
コメント
There are no comments made yet.
jaume 承諾済みの回答
The result of sql statment returns null in the field camp that is a blob field containing the imag when no there is a image and it is correct. However, in the report insted of print null or empty, it prints the previous image.

runing the report from valentina studio it works fine.
コメント
There are no comments made yet.
jaume 承諾済みの回答
creating a new report it works ok
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
So the problem is solved in a new report?
If you still have an old report - can you attach it so we'll be able to analyze it?
コメント
There are no comments made yet.
  • ページ :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories