1. Shawn Kanyer
  2. Valentina Studio
  3. 火, 10月 13 2020, 01:57 PM
  4.  メールで購読
After this last update, I am seeing large slow downs while trying to open a Postgres database. When expanding the public folder, I've seen it lock up my pc for a few minutes and the studio become unresponsive. And I've also seen it expand showing me all the subfolders, but have three dots to the right of it appearing to indicate that it is working on loading the objects. After two or three minutes, it does load and all back to normal. Prior to this update I had no issues opening my database.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
A lot of optimisations were made for this issue in version 10.5.5.
It is now available for download.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Thank you, I reproduced the problem.
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
Perhaps this will help.
添付ファイル
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
The version released today still suffers this problem. I expanded the public folder and it took five minutes to load and made my music stop sporadically. After it loaded, all the text in Windows started to go away and I had to restart. Rolled back to version 10.5 and again the problem is gone.
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
The about just says 10.5 built on 9 sept. The schema has 22 tables, 6 functions, and 13 views.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
So now you’re running 10.5.2, right? What about your schema - how many tables in it?
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
I rolled back to the prior version and I'm immediately back to normal.
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
I can also see this issue when in the sql editor and I expand a table to see the Checks, Fields, Indexes, etc. Expanding the fields in particular does not seem to cause it.
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
I'm running postgres 10.5.
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
SQLite seems fine. I opened a tiny test postgres db, and it took five seconds to load. No big problem, but still slow. Opening another small postgres database and the public folder drops down, but I get loading symbols next to the file names. It doesn't always lock up my computer, but it certainly is slow for all my postgres db.
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
After a restart, I'm back to normal. This happened earlier today as well, but I did not realize valentina caused it.
添付ファイル
コメント
There are no comments made yet.
Shawn Kanyer 承諾済みの回答
I had it open all day. I tried to investigate further to give you more context. I opened a different database. As soon as I expanded the public folder, it entirely locked up my pc for three to five minutes. Now, I can see it had a negative effect on Windows that I have to restart to recover from. All the text in the task manager is not there, I only see the icons for all the programs. The file explorer has no text. The text for the items on my desktop are black shadows.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Can't reproduce for now. Does it happen just with any database?
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Hello Shawn,

Thank you, we'll recheck it.
コメント
There are no comments made yet.
  • ページ :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories