1. Frank Lemke
  2. Valentina Database ADK
  3. 月, 9月 07 2020, 09:45 AM
  4.  メールで購読
Hi, is there any info about when you may have (a beta version of) V4CC for Apple Silicon (universal binary) available?

Thanks
Frank
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
No, we don't have the hardware yet.

But I can't run it even on Catalina, exactly the same message was shown.

Changing the quarantine attribute helped:
xattr -dr com.apple.quarantine My\ Application.app
コメント
There are no comments made yet.
Beatrix Willius 承諾済みの回答
I'm trying to do codesign manually because Xojo doesn't do post-build scripts for the universal app. But I get an error when codesigning vcomponents:

beatrixwillius@Beatrixs-MacBook-Air ~ % /usr/bin/codesign --timestamp -f -s 'Developer ID Application: Beatrix Willius (72695Z3887)' /Users/beatrixwillius/Desktop/My\ http://Application.app/Contents/vcomponents_x64/*
/Users/beatrixwillius/Desktop/My http://Application.app/Contents/vcomponents_x64/libvclient_fat_release_x64.dylib: replacing existing signature
/Users/beatrixwillius/Desktop/My http://Application.app/Contents/vcomponents_x64/libvkernel_fat_release_x64.dylib: replacing existing signature
/Users/beatrixwillius/Desktop/My http://Application.app/Contents/vcomponents_x64/libvshared_fat_release_x64.dylib: replacing existing signature
/Users/beatrixwillius/Desktop/My http://Application.app/Contents/vcomponents_x64/vresources: bundle format unrecognized, invalid, or unsuitable
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Looks like codesign doesn't work when a bundle has non-standard structure.

Some time ago we made changes to place vcomponents and vresources to the standard paths

app/Contents/Frameworks/vcomponents_64
app/Contents/Resources/vresources

install_vcomponents_v4rb doesn't reflect these changes, I'll update it soon.
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Here's the script. In my tests, codesign works with this structure
添付ファイル
コメント
There are no comments made yet.
Beatrix Willius 承諾済みの回答
Built the app again and did the codesign manually. It starts fine on a DTK and crashes without crash log when starting to use Valentina. There is no information in the Console. I tried to start the app with Terminal "open app". But there is no information.:(
コメント
There are no comments made yet.
Sergey Pashkov 承諾済みの回答
Is it possible to try to run the Valentina Server on the DTK? To know if the problem is V4RB-related or Valentina ARM build just doesn't work.

I uploaded the installer.
Also, I uploaded the server in a zip archive, running it from some home folder shows a log in the terminal:
vserver_universal/vserver_x64.app/Contents/MacOS/vserver_x64
参照
  1. https://www.dropbox.com/s/22y48xgifaam4y2/vserver_x64_10_mac.dmg?dl=0
  2. https://www.dropbox.com/s/iwzpbo0p0qpyvi0/vserver_universal.zip?dl=0
コメント
There are no comments made yet.
Jonathan Ashwell 承諾済みの回答
To follow up -- I built as a Universal and sent it to someone with an M1 Mac...he reports there are no obvious problems. So for me at least (using the V4RB ADK) all seems to be well. Thanks for your work on this.
コメント
There are no comments made yet.
Beatrix Willius 承諾済みの回答
I thought I'd try again. But even with the new script I still get an error on codesign.

/usr/bin/codesign --timestamp -f -s 'Developer ID Application: Beatrix Willius (72695Z3887)' /Users/beatrixwillius/Desktop/My\ Application.app/Contents/Frameworks/*
/Users/beatrixwillius/Desktop/My Application.app/Contents/Frameworks/SQLiteDatabase.dylib: replacing existing signature
/Users/beatrixwillius/Desktop/My Application.app/Contents/Frameworks/XojoFramework.framework: replacing existing signature
/Users/beatrixwillius/Desktop/My Application.app/Contents/Frameworks/v4rb_cocoa_64.dylib: replacing existing signature
/Users/beatrixwillius/Desktop/My Application.app/Contents/Frameworks/vcomponents_x64: bundle format unrecognized, invalid, or unsuitable
コメント
There are no comments made yet.
Beatrix Willius 承諾済みの回答
I'm an idiot. I needed to codesign the subfolder:

/Users/beatrixwillius/Desktop/My\ http://Application.app/Contents/Frameworks/vcomponents_x64/*
コメント
There are no comments made yet.
Beatrix Willius 承諾済みの回答
I'm not officially out of ideas. I built again. Did a codesign and notarised the app. It starts fine and then it crashes. I don't have sudo access to this computer.

@Jonathan Ashwell: do you have a link to your app as ARM version?
コメント
There are no comments made yet.
Beatrix Willius 承諾済みの回答
Did some more testing with the most simple method of debugging using messageboxes:


// LOCAL MODE:
if( gClient = false ) then
Valentina.Init( mCacheSize )

if Valentina.CacheSize = 0 then
MsgBox "Valentina was not initialized!"
end if
end if

MessageBox "Will init Valentina"

// CLIENT MODE
if (gClient = true) then
Valentina.Init(100 * 1024 * 1024, "", "")
Valentina.YieldMode = False
end if

Messagebox "Valentina inited"

// -------------------------------------
// Set debug level for Valentina plugin logs.
Valentina.DebugLevel = EVDebugLevel.kLogParams

MessageBox "Log params set"


I get the messageboxes "Will init Valentina" and "Valentina inited". I don't get "Log params set".
コメント
There are no comments made yet.
  • ページ :
  • 1
  • 2


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 2 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories