1. Helge Tjelta
  2. Valentina Server
  3. 木, 11月 21 2019, 08:26 PM
  4.  メールで購読
Hi, I'm doing a select with some WHERE with AND and OR...

But it differs from server 6.5.3 to 9.7 in a great way....

because of my use of f1>f2_t2 I don't get consistent result... it will now NOT use the where before AND...

i.e.(byraa is the ID for companyID).
SELECT RecID, personnr, navn, postnr, adresse, poststed, kommune, land, trossamfunn, sivilstand, statsborgerskap, doeddato, kode, byraa, OpprettetAv, OpprettetAv->ID as brukerID
FROM avdoed WHERE byraa = '1' AND (navn LIKE '%Tjelta%' OR Poststed LIKE '%Tjelta%' OR land LIKE '%Tjelta%' OR Kode LIKE '%Tjelta%' OR Personnr LIKE '%Tjelta%' OR doeddato LIKE '%Tjelta%' OR kommune LIKE '%Tjelta%' OR adresse LIKE '%Tjelta%' OR pers_fester->navn LIKE '%Tjelta%' OR seremoni->Gravsted_sistGravlagt LIKE '%Tjelta%' )
ORDER BY Kode DESC
LIMIT 25

using the -> for name search I get result of both byraa 1 and byraa 2.... I should only have byraa 1, since that is the value of byraa in my search...

Doing the same in server 6.5.3, it works perfectly... but doing it in 9.7, it does not use the byraa value at all...

If I remove the -> parameters, then it works in 9.7.... so it is doing something wrong with the -> operator...

Broken ?
コメント
There are no comments made yet.
Helge Tjelta 承諾済みの回答
I se now that it might have something to do with the links...

the seremoni-> linking works... but this one have a link further to byraa...

the person_xxx-> links don't have this further link...

maybe.
コメント
There are no comments made yet.
Helge Tjelta 承諾済みの回答
Well it was not the links...
コメント
There are no comments made yet.
Helge Tjelta 承諾済みの回答
but this ->

seremoni->Gravsted_sistGravlagt LIKE '%Tjelta%'

does not cause problems.... only those others...with person in them...
コメント
There are no comments made yet.
Helge Tjelta 承諾済みの回答
setting the value of byraa (company ID), to 2, 3,4, 5 all gets different things... 3 is nothing

1 and 4, 5 gives the same result (2 of byraa 2, and 1 of byraa 1) = should been only one of byraa 1
2 a lot more... (6 records of byraa2, and 1 record of byraa 1)
6 (2 of byraa 2, 1 of byraa 1 and 1 of byraa 6)

Strange....
コメント
There are no comments made yet.
Helge Tjelta 承諾済みの回答
testing with some of the other -> uses, I get totally different results...

looks like a lot have changed in linking tables ?
コメント
There are no comments made yet.
Ruslan Zasukhin 承諾済みの回答
Hi Telge,

quick answer - nothing was changed in Links during the last years.

It is hard to say if something is broken compared to 6.5, but all our VDB tests are done 100%, testing happens each day.

I think we need some simple DB and you query you try, and
a) what you get
b) what you expect

yes I see above something, but please drop into Mantis.
コメント
There are no comments made yet.
Helge Tjelta 承諾済みの回答
matis ID: 0008692
コメント
There are no comments made yet.
Ivan Smahin 承諾済みの回答
It is fixed and will be available nearest time in v.9.7.2 build.
コメント
There are no comments made yet.
  • ページ :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories