1. Smart City doo
  2. Valentina Server
  3. Понедельник, Март 02 2020, 08:38 PM
  4.  Подписаться через email
What is properly syntax of "absolute_path"

I tried:
BACKUP DATABASE TO "\\server\share\"
but I got error: File E:\databases\\\server\share\.vdb" does not exist.
Комментарий
There are no comments made yet.
Ivan Smahin Ответ принят
Fixed in v.10.0.2.
Комментарий
There are no comments made yet.
Ivan Smahin Ответ принят
Комментарий
There are no comments made yet.
Aleksandar Spasojevic Ответ принят
Hello Ivan,

I just tried

SET PROPERTY SystemBackupCatalog OF SERVER TO 'E:\backup'


After that, backup went to selected location.
Next step was to return path to default.

SET PROPERTY SystemBackupCatalog OF SERVER TO 'D:\DB_BACKUP'


Backup database after that also went to 'E:\backup' , but GET PROPERTY shows new location.
Комментарий
There are no comments made yet.
Ivan Smahin Ответ принят
One more thing - currently Valentina does not support "network file-path notation" like "\\server\share\...". You should map it to make it available as a regular path like "F:\..."
Комментарий
There are no comments made yet.
Ivan Smahin Ответ принят
I guess you are trying to do backup under vServer to the arbitrarily folder on vServer side. It is not allowed, you can do so only in the "local" mode. vServer's backups are placed into SYSTEMBACKUPCATALOG which is defined in the ini file (Also you may see/change that setting via SQL - "SHOW PROPERTIES OF SERVER"/ "GET/SET PROPERTY .... OF SERVER ..." ).

So, you can do only "BACKUP DATABASE" under vServer.
Комментарий
There are no comments made yet.
  • Страница :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.