1. Cecilio
  2. Report Editor
  3. Воскресенье, Март 11 2018, 08:55 AM
  4.  Подписаться через email
Hi.
The currency format does not show decimals.
ejmplo: 4.15 you see how 4.00 €

Instead of seeing 15 shows 00

How can it be solved without putting a pattern on all the fields?
Or can you create a standard pattern that replaces the one of currency format?

I use linux.
Комментарий
There are no comments made yet.
Sergey Pashkov Ответ принят
Hi Cecilio,

That's strange. Looks like the format is not recognized.
What database is used?
If you execute select with this field you get 4.15 with a dot as the separator, right?
Комментарий
There are no comments made yet.
Cecilio Ответ принят
Resolved. It only looks like this in the report editor, preview option.

In real it prints correct: 4.15 €

Excuse me.
Комментарий
There are no comments made yet.
Cecilio Ответ принят
Hello, the problem persists.
Decimals are not seen in preview or in real time.

I have tried to type "Number" and format: "#, ## 0. ## €" Decimals are not seen either.

What can be the problem?
Комментарий
There are no comments made yet.
Sergey Pashkov Ответ принят
Hello, Cecilio,

Please add details - what database is used, is everything on Linux?

If you execute SELECT in the SQL Editor - what is the format of these values?
Комментарий
There are no comments made yet.
Cecilio Ответ принят
MariaDB
if execute SELECT the format is 12.50 for example. All number have decimals
Комментарий
There are no comments made yet.
Sergey Pashkov Ответ принят
I think the problem is in the locale: when the conversion from string to number happens a wrong decimal-point character is expected.
I'll check it.
Комментарий
There are no comments made yet.
Cecilio Ответ принят
I have changed the format and so: #.##0,0# so it works
But I'm worried that other computers stop going.
Spanish language
Комментарий
There are no comments made yet.
Sergey Pashkov Ответ принят
We reproduced the problem and working on the solution now.
Комментарий
There are no comments made yet.
Sergey Pashkov Ответ принят
Hello Cecilio,

The fix is available in the version 8.6.3:
http://valentina-db.com/download/release/lin_64/

As always it is necessary to update the Valentina Studio and Xojo plugin to see changes.
Комментарий
There are no comments made yet.
Sergey Pashkov Ответ принят
Hi Cecilio,

Have you already tried a new build?
Комментарий
There are no comments made yet.
  • Страница :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.

Categories

Announcements & News
  1. 0 subcategories
Valentina Studio
  1. 2 subcategories
Valentina Server
  1. 4 subcategories
Valentina Database ADK
  1. 0 subcategories
Valentina Reports ADK
  1. 0 subcategories
Other Discussions
  1. 0 subcategories
BETA Testing
  1. 0 subcategories
Education & Research
  1. 0 subcategories
Omegabundle
  1. 0 subcategories